Add new comment

Submitted by drguild on Fri, 11/18/2022 Permalink

This firmware needs a update for Marlin 2.1.1 which has become the standard firmware now.

BigtreeTech's Touchscreen's which I have now have a minimum Marlin 2.1.1 dependency now.

Plus a bunch of bug fuzes about SPI and other things printing quality related have been introduced.

https://github.com/bigtreetech/BIGTREETECH-TouchScreenFirmware

Marlin Dependencies

Minimum Marlin firmware version: 2.1.1
Distribution date: 2022-08-06

The content of this field is kept private and will not be shown publicly.